Hellgate Revival :: Forums

Community => Support => Topic started by: Deviljade on Nov 03, 2017; 04:33 PM

Title: Certain text missing in interface
Post by: Deviljade on Nov 03, 2017; 04:33 PM
Earlier this year I was playing HGL with the Revival mods without any trouble. I picked the game up again a few weeks ago and noticed that text was missing from a lot of the interface. I chalked this up to some issue with mods, so I removed them all and then uninstalled and re-installed the game.

I loaded it up after a fresh install, and the issue is still there (without any mods installed). I have tried compatibility mode, various resolutions, etc. Nothing seems to work. Super bummed  because I can't really play the game in this state. I am attaching a screenshot for an example. Some item details are missing and the entire stat page is blank. Items on the ground have no info, the map spots are all blank as well as tunnel entrances/exits, etc.

I'd love to hear some ideas. I am running Windows 10 version 10.0.15063

I haven't changed anything about my computer since the game was working correctly roughly back in February-April, except done Windows Updates.

Title: Re: Certain text missing in interface
Post by: Deviljade on Nov 05, 2017; 10:08 PM
Just an update... I tried uninstalling again, and manually deleted the Flagship studios folder, as well as the Hellgate folder from My Games. After installation it still occurs. I tried changing the Language.dat to another language, and although I get missing text string warnings on text boxes that currently work, the same ones remain empty.

I've also tried Windows in Safe Mode and without a graphics card driver, both attempts resulted in the same problem. I installed the game on my work laptop and text appears fine.

I also noticed a strange empty box in the center of my screen when targeting enemies, see attachment.

Is anyone aware of registry changes that occur with mod installations that could possibly still be persisting through this uninstall/reinstall cycle?
Title: Re: Certain text missing in interface
Post by: Malachor on Nov 06, 2017; 12:40 AM
I have never seen this issue before.
When you said that you picked the game up again, do you mean that you started playing it again, or something else?

Had you made any changes to your computer between when you last played and now?

Did you revert the mods with the mod launcher, or manually delete the files?

Have you installed either the SP1.2, or MP2.0 patches?
Title: Re: Certain text missing in interface
Post by: Deviljade on Nov 06, 2017; 04:46 PM
I just started playing it again, I had left the game and mods untouched.

Besides Windows Updates, no.

The mods were reverted with the launcher first, and prior to my first uninstallation it had both patches I believe since that was required for Revival. Once I had cleared everything out I did just the SP Patch and tried Lost London V but had the same issues. Then I realized that the problem occurred with fresh installs without any mods.

I reformatted the computer, and that resolved the issue. It was my least desired option but it got the job done. Still very curious what exactly it was all about though. I checked the registry for Flagship studios under HKLM and HKCU but just found start menu stuff, and something for the Reanimator but that pointed to just the install location, so I assumed that would have no impact. I had also tried creating a new User Profile but that didn't resolve it either. So fresh install of Windows saved the day, now I can enjoy London 2038  :D Appreciate the reply!
Title: Re: Certain text missing in interface
Post by: Malachor on Nov 07, 2017; 12:27 AM
Now that you've got it working again, have you checked for any registry entries?