Author Topic: SP 1.2 Patch Gives Errors, Can I get some help?  (Read 183 times)

ben_roprim

  • Nameless
  • *
  • Posts: 7
  • Karma: 0
SP 1.2 Patch Gives Errors, Can I get some help?
« on: Apr 07, 2017; 12:57 PM »
First, I wanna thank Administrator Nitehawk for helping me get my new Hellgate CD from Amazon, thanks man! Just came in a few days go, and works like a charm!

However, it seems it's not all sunshine and rainbows when it comes to installing the SP 1.2 Patch, as it gives some errors when executing the file.

The following errors occur:

- "Launcher could not find language.dat"
- "Failed to load strings"

I find it strange, cause I did indeed install the launcher provided in: http://www.hellgateaus.info/modification/

However my launcher doesnt look like the one in the picture too, so that could be a problem too.

So is it alright if I can get some help setting up the SP 1.2 Patch?

Thanks in advanced!



NiteHawk

  • Administrator
  • Dark Will
  • *****
  • Posts: 514
  • Karma: 8
  • Lurking in the shadows
Re: SP 1.2 Patch Gives Errors, Can I get some help?
« Reply #1 on: Apr 07, 2017; 01:37 PM »
Hi ben_roprim!

That's sounds a bit like you might be mixing things up. The "launcher" that the SP patch relates to in its error message should be the original FSS launcher and should be unrelated to those that some of the SP mods brought with them. It's still a bit unusual/puzzling that it would complain about a missing language.dat.

Anyway: You should probably repeat the installation steps in the proper order (if all else fails: uninstall Hellgate and start afresh). The preferred way is to install the "vanilla" game first (via setup.exe). After that, apply the SP 1.2 patch - before you attempt to add any kind of modification. Launch the game once and make sure the startup screen shows the expected version (1.18074.70.4256) in the lower right corner. It's only after this that you should continue with "mod" installation - preferably even create a backup (e.g. zip the entire folder) of your Hellgate installation in this state. (So you can easily revert to it if the need arises.)

Regards, NiteHawk

[EDIT] You might also want to cross-check http://www.hellgateaus.info/forum/support/patching-to-1-2-language-dat-missing/
« Last Edit: Apr 07, 2017; 01:44 PM by NiteHawk »
"'Chocolate Park' sounds... suspiciously cute."

ben_roprim

  • Nameless
  • *
  • Posts: 7
  • Karma: 0
Re: SP 1.2 Patch Gives Errors, Can I get some help?
« Reply #2 on: Apr 07, 2017; 01:57 PM »
Ah crap, maybe because I installed the launcher first bfore the SP 1,2?

But I am gonna uninstall and reinstall real fast and see if it helps doing it the other way around.

Sidenote, the making of the language.dat didn't work. I think I indeed needed to use a fresh install first.

Trying it out now.

ben_roprim

  • Nameless
  • *
  • Posts: 7
  • Karma: 0
Re: SP 1.2 Patch Gives Errors, Can I get some help?
« Reply #3 on: Apr 07, 2017; 02:11 PM »
I got the error again, but I think I know what's wrong.

For some reason it's destination of extraction is going to my /appdata/temp/ folder.

I cannot seem to change it's location too, as it immediately starts to unpack there. And canceling just closes the patching all together.

So what should I do now?


NiteHawk

  • Administrator
  • Dark Will
  • *****
  • Posts: 514
  • Karma: 8
  • Lurking in the shadows
Re: SP 1.2 Patch Gives Errors, Can I get some help?
« Reply #4 on: Apr 07, 2017; 04:15 PM »
You may get bitten by "File and Registry Virtualization" on newer Windows versions (see https://en.wikipedia.org/wiki/User_Account_Control#Features).

Try to execute both setup.exe and the patcher with administrative rights (right-click the executable, "Run as administrator").

Regards, NiteHawk
"'Chocolate Park' sounds... suspiciously cute."

ben_roprim

  • Nameless
  • *
  • Posts: 7
  • Karma: 0
Re: SP 1.2 Patch Gives Errors, Can I get some help?
« Reply #5 on: Apr 08, 2017; 03:03 AM »
Hey Nitehawk, it worked and you were right!

It was a registry problem with my OS, and both Setup.exe and the patch under "Run as admin" did the trick!

Now I will try to get this stuff working, so I can finally get to playing Lost London!

If I come into any other problem, I will let you know here.

Thanks again Nitehawk for everything you done, from helping me purchase Hellgate, to helping get Mod-Ready.


ben_roprim

  • Nameless
  • *
  • Posts: 7
  • Karma: 0
Re: SP 1.2 Patch Gives Errors, Can I get some help?
« Reply #6 on: Apr 08, 2017; 03:16 AM »
Posting again to confirm everything now works 100% perfect!

Thank you SO much again, Nitehawk.

You've been a blessing!

NiteHawk

  • Administrator
  • Dark Will
  • *****
  • Posts: 514
  • Karma: 8
  • Lurking in the shadows
Re: SP 1.2 Patch Gives Errors, Can I get some help?
« Reply #7 on: Apr 08, 2017; 09:51 AM »
Good to know that you were able to solve this now. And: You're welcome. :)

Regards, NiteHawk
"'Chocolate Park' sounds... suspiciously cute."