Author Topic: patching to 1.2 language.dat missing  (Read 8603 times)

pk10222

  • Nameless
  • *
  • Posts: 5
  • Karma: 0
patching to 1.2 language.dat missing
« on: May 27, 2011; 08:33 AM »
So on my 64-bit machine i can install the 32 bit hellgate no problem. When i try to patch it to 1.2 i get the "language.dat is missing" message and was wondering if there is a way to manually patch it.

Kite

  • Developer
  • Eldest
  • ****
  • Posts: 1095
  • Karma: 3
Re: patching to 1.2 language.dat missing
« Reply #1 on: May 27, 2011; 10:14 AM »
The language.dat is a small text file that is located inside of the "Hellgate LondonData" folder and only contains information about which ingame language is currently used. In case it is missing you can easily re-create it yourself:

1. Create a new txt file and open it in a text editor
2. In the first line add "Language=English" (or French, German, Spanish whatever, without the ")
3. Save and close the file and rename it to "language.dat"
4. move the file to the "Hellgate LondonData" folder
~ Recettear ~
Capitalism, ho!

pk10222

  • Nameless
  • *
  • Posts: 5
  • Karma: 0
Re: patching to 1.2 language.dat missing
« Reply #2 on: May 27, 2011; 05:22 PM »
Ah i tried that before but it didn't work. I had left "" in there :shock:  i feel stupid for not trying that. Thanks for the reply  :mrgreen:

pk10222

  • Nameless
  • *
  • Posts: 5
  • Karma: 0
Re: patching to 1.2 language.dat missing
« Reply #3 on: May 27, 2011; 06:06 PM »
Unfortunately now it says "Error:Failed to find Helgate London" when i try to patch it.

Apparently it has the launcher as 64 bit and i only have the 32 bit game files.

ElectricMessiah

  • Nameless
  • *
  • Posts: 64
  • Karma: 0
Re: patching to 1.2 language.dat missing
« Reply #4 on: May 28, 2011; 12:51 AM »
What OS?  I'm assuming Vista or 7 64bit OSs.

Here is a bunch of stuff in no particular order.

D/L and try Gboost.  It safely shuts down services that are not needed when playing games.  However, it is also useful for other tasks when you shut down quickly and safely.  I  like it.
http://http://www.gzero.com/gboost/home.html.  Free simple utility with no ads/spyware.

Try running the patch in XP compatibility mode.

Try also running HGL in compatibility mode.
Uninstall/Delete left over directory.

Reinstall on C: in the default directory.
Call Flagship Customer Service and raise Hell.

Make sure your patch and HGL are both for the same region.  
The German version cannot be patched with the NA version, as an example.

I hope something in here helps.  I'd go the Gboost route first.

pk10222

  • Nameless
  • *
  • Posts: 5
  • Karma: 0
Re: patching to 1.2 language.dat missing
« Reply #5 on: May 28, 2011; 07:48 AM »
Im actually running on windows 7. and it has nothing to do with performance its just with hellgates installation.  There was a way to manually patch the 32 bit to 1.2 but the binarie and data rars no longer exist on rapid share so i was hoping someone else had a work around. i rather not do a virtual xp install since im kind of lazy. lol  :shock:

Kite

  • Developer
  • Eldest
  • ****
  • Posts: 1095
  • Karma: 3
Re: patching to 1.2 language.dat missing
« Reply #6 on: May 28, 2011; 10:11 AM »
Ah... so you're using the 32-bit exes on your 64-bit OS? Do you also have the 64-bit exes in their correct folders? If not, that's probably the problem then... Try using/restoring the 64-bit exes and installing the patch again.
~ Recettear ~
Capitalism, ho!

pk10222

  • Nameless
  • *
  • Posts: 5
  • Karma: 0
Re: patching to 1.2 language.dat missing
« Reply #7 on: May 29, 2011; 06:49 AM »
i know where you are coming from and i have done that. the problem is i want JUST the 32bit install nothing with the 64-Bit i know it doesn't make to much sense to have 32 bit when i can have 64 bit but there is some reasoning behind it. i am very grateful you are trying to help me out though.

Kite

  • Developer
  • Eldest
  • ****
  • Posts: 1095
  • Karma: 3
Re: patching to 1.2 language.dat missing
« Reply #8 on: May 29, 2011; 12:40 PM »
The thing is:
I don't think you CAN install the 32-bit patch on a 64-bit system. Under normal circumstances the game will only install/add the 64-bit exes to the game folder, so my guess is that the patch will also only look for the 64-bit executables on your 64-bit system. Because of that you most likely need the 64-bit exes in their folders no matter wether you actually use them or not (otherwise you wouldn't get that error).

The difference between 32 and 64-bit are just the exes and the associated DLLs, so the only option I'm seeing is for you to find these missing files and add them.


A virtual XP is a nice idea but it won't help you in this case. The software is based on "Virtual PC" which was primarily developed for office desktops and thus only offers extremely limited graphics card emulation capabilities. Movies and other media like that is about all you can get to run on it, but about 99% of all games won't work because of the missing main functionalities: no shaders, no DirectX, no Direct3D, no OpenGL...
Another tool like "Virtual PC" is "Virtual Box" which actually offers a decent emulated graphics card featuring OpenGL support, but still lacking the much needed DirectX for HGL.

Result:
Virtualization environments like that are perfect for business and office systems, but aren't meant to be used for gaming.
~ Recettear ~
Capitalism, ho!

Ztox

  • Nameless
  • *
  • Posts: 1
  • Karma: 0
Re: patching to 1.2 language.dat missing
« Reply #9 on: Nov 13, 2015; 06:46 PM »
Hey guys


I had the same problem and I looked everywhere for ways to make it work.
ALL you have to do is just install it with the general "setup" in the location the game has by default, select your language and region and all the files you need will be there. But the game will install a 64bit version if your pc is 64bit based.