Hellgate Revival :: Forums

Community => Support => Topic started by: sarcarx on Dec 07, 2018; 10:30 PM

Title: Invalid or missing SKU/1.2 SP and 2.0 MP patch
Post by: sarcarx on Dec 07, 2018; 10:30 PM
Hi,

I have installed the problem from steam, and I was trying to get some mods installed.
I downloaded the launcher from this thread :
http://www.hellgateaus.info/forum/hellgate-london-modification-downloads/the-'new'-launcher-(for-revival-1-5-and-up)/
So I unzipped the launcher into the game's folder, I tried starting it and it seems to work.
But both 1.2 SP and 2.0 MP patches ask me for the launcher's path, and then give me this weird error :
"Invalid or missing SKU"
I feel like this may be caused by the fact that I didn't install my game in the default path but it is just a guess. Could anyone help me debug that?

Title: Re: Invalid or missing SKU/1.2 SP and 2.0 MP patch
Post by: Malachor on Dec 08, 2018; 01:28 AM
The patches aren't compatible with the steam version. And you'll probably find that most, if not all, mods are also not compatible with the steam version.
If you want to play with any of the mods on this site, you'll need to find the old version of the game.
Title: Re: Invalid or missing SKU/1.2 SP and 2.0 MP patch
Post by: Stygian27 on Dec 23, 2018; 07:16 PM
I have the same issue as you sarcarx.  I bought the game off amazon (key was good) and installed without an issue.  I then downloaded the launcher, sp 1.2, and mp 2.0 from the links on this site.  Once I tried to install the sp patch i got "Missing or Invalid SKU".
Title: Re: Invalid or missing SKU/1.2 SP and 2.0 MP patch
Post by: Morphy on Dec 23, 2018; 09:49 PM
Are you guys non-English?

This errors is a known thing (from my searches) - you have to install the game in English for it to put in the sku.

If you ARE doing that, I'll keep looking for answers for you.


I wonder if it'd help to post my file?   Let's try.

It goes in the "data" subfolder. Dunno if it's linked or locked to my specific installation, but let's try, hey?

Download here:

http://s000.tinyupload.com/index.php?file_id=69581828439965595154

Delete it when you got it, here

http://s000.tinyupload.com/index.php?del_id=00789511368063158748

Title: Re: Invalid or missing SKU/1.2 SP and 2.0 MP patch
Post by: Kikina the templar on Dec 23, 2018; 10:03 PM
Oh, Morphy was faster   ;D   But, when i wrote it already..

As Malachor has already said - steam version of Hellgate cannot be patched.
If you have old client from 2007, then sku error is ALWAYS something about region. For example Hellgate client for oceania cannot be patched with patches for european version.

You can try swap sku files in your client data folder with files from european version (attached zip), but this procedure is not tested.
Title: Re: Invalid or missing SKU/1.2 SP and 2.0 MP patch
Post by: Stygian27 on Dec 24, 2018; 01:30 AM
So I reinstalled a 3rd time and both patches went through.

Thanks all for the help.