Author Topic: Installing Revival 1.5  (Read 1933 times)

Iftik

  • Nameless
  • *
  • Posts: 20
  • Karma: 0
Installing Revival 1.5
« on: May 29, 2015; 09:01 PM »
hello, I ave big problems installing the game modification. I played the german version of the game, but since the cube is extremely bugged, I decided to change to english. I have an old MULTI-lingual CD, so I installed game in english. Now I hate to get the SP 1.2 patch and the 2.0 MP patch. And here we go. Every site I try to get those 2 automatically let me download the europe_german patches for an uknown reason. I can't install them on english version of the game because it will crash in the main menu. Where can I get those 2 patches in english_North America version so my game stays in english and I can play it and using the Revival 1.5b mod?
P.S. Even the attachments/links in this forum always get me german patches...

NiteHawk

  • Administrator
  • Dark Will
  • *****
  • Posts: 529
  • Karma: 8
  • Lurking in the shadows
Re: Installing Revival 1.5
« Reply #1 on: May 29, 2015; 09:44 PM »
Hello Iftik!

Something is wrong there, though I can't exactly pinpoint from where your troubles seems to origin.

There are no separate SP 1.2 patches for "English" or "German". That's why the download file originally was named Patch_NA_Europe_Germany_SP_1.2_(1.18074.70.4256).exe - which indicates it is for the North America and Europe regions. (The only other SP 1.2 patch I am aware of is Patch_SEA_SP_1.2_1.18074.6.zip, which applies to the South-East-Asia versions.)

If I remember correctly, the game distinguishes its "region code" via the file Data\sku.sku. Maybe your installation somehow has that file "wrong", i.e. still indicating the German localization...

Also double-check this forum thread, maybe there's a useful tip in there somewhere.

Regards, NiteHawk
"'Chocolate Park' sounds... suspiciously cute."

Iftik

  • Nameless
  • *
  • Posts: 20
  • Karma: 0
Re: Installing Revival 1.5
« Reply #2 on: May 29, 2015; 11:41 PM »
Okay. If I install the 2 patches, the game works in english. If I install 1.2.1 Revival. the game works. If I install 1.5b, the game crashes in main menu.  :(
The error says something like application 0x40037 da2 read/save error 0xffffffff.
« Last Edit: May 30, 2015; 12:13 AM by Iftik »

RedChaos

  • SpamBot
  • Founder
  • Named
  • **
  • Posts: 258
  • Karma: 4
Re: Installing Revival 1.5
« Reply #3 on: May 30, 2015; 02:34 AM »
Install Hellgate London. Install the official patches. Then run both the single player and multiplayer EXEs once. Then only install the 1.5 fan patch. It is either install the 1.2.1 fan patch or the 1.5b fan patch. Not both. The game must be run before you install either patch.

Even though there is no longer a Multiplayer server you still need to run the multiplayer exe or the game won't work right.

I have no clue what else it might be. You might also try running the game as administrator and see if that helps.

Iftik

  • Nameless
  • *
  • Posts: 20
  • Karma: 0
Re: Installing Revival 1.5
« Reply #4 on: May 30, 2015; 02:42 AM »
Wow. Starting the MP once helped. Thanks. I read about the need of starting the SP, and I did that when I installed the mod first time some days ago, but back then it worked without starting the MP. Still, Thank You.