Author Topic: Announcing the Augmentrex project (includes a fix for the 1 FPS bug) - v2.0.0  (Read 10879 times)

RomaMartin

  • Nameless
  • *
  • Posts: 24
  • Karma: 0
I do not understand how to call the console for command inputs?

Zor

  • Nameless
  • *
  • Posts: 14
  • Karma: 1
What do you mean by "call the console"? I'll need more details to help.

RomaMartin

  • Nameless
  • *
  • Posts: 24
  • Karma: 0
in order to enter the command? to remove the fps drop

Zor

  • Nameless
  • *
  • Posts: 14
  • Karma: 1
Just run Augmentrex? Two console windows will pop up, one of which is the command interpreter.

zeneye

  • Nameless
  • *
  • Posts: 2
  • Karma: 0
how do you download or use this stuff i dont understand any of this... is there a step by step to installing and using this stuff? im completely confused

zeneye

  • Nameless
  • *
  • Posts: 2
  • Karma: 0
it looks like you have to know code to use this... i will never be able to figure this out, and i ahve to run visual software and net framework software? what is this stuff?

Dorogochi

  • Nameless
  • *
  • Posts: 2
  • Karma: 0
When trying commands ill get "No matches. Was the game updated?" im on 2.1.0.4 ... this is outdated mod or ?

Zagnard

  • Nameless
  • *
  • Posts: 4
  • Karma: 0
Howdy,

excuse me, I was trying to get this to work, and got the following crash:

Host assembly crashed: System.ArgumentException: STATUS_INVALID_PARAMETER_1: The given process file does not exist. (Code: 3)
   at EasyHook.NativeAPI.Force(Int32 InErrorCode
   at EasyHook.NativeAPI.RtlCreateSuspendedProcess(String InEXEPath, String InCommandLine, Int32 InProcessCreationFlags, Int32& OutProcessId, Int32& OutThreadId)
   at EasyHook.RemoteHooking.CreateAndInject(String InEXEPath, String InCommandLine, Int32 InProcessCreationFlags, InjectionOptions InOptions, String InLibraryPath_x86, String InLibraryPath_x64, Int32& OutProcessId, Object[] InPassThruArgs)
   at EasyHook.RemoteHooking.CreateAndInject(String InEXEPath, String InCommandLine, Int32 InProcessCreationFlags, String InLibraryPath_x86, String InLibraryPath_x64, Int32& OutProcessId, Object[] InPassThruArgs)
   at Augmentrex.Program.Main() in C:\Users\alex\Documents\Visual Studio 2019\Projects\Augmentrex\Augmentrex\Program.cs:line 53

I'd be most gratefull if you could aid me with this. And also, great job :) .
« Last Edit: Jan 02, 2020; 07:05 PM by Zagnard »

chaos0ne

  • Nameless
  • *
  • Posts: 24
  • Karma: 0
any plans to release 3.0.0?
maybe that you and enemies cant to shoot trought walls

NasierAlcofibras

  • Nameless
  • *
  • Posts: 4
  • Karma: 0
Hello all !

I am a long time fan of the original game.

It seems the plugin to Augmentrex does not work, on my system, with version 2.1.0.4 of the Steam flavor of the game. (I now know it was made for version 2.1.0.4 so it should work.)

I don't know the reason why it does not work for me and would appreciate help in making it work for me.

[However see my next message below where I give details about what I checked.]

Thanks !
« Last Edit: Aug 25, 2020; 08:28 AM by NasierAlcofibras »

Zor

  • Nameless
  • *
  • Posts: 14
  • Karma: 1
What do you mean? It's specifically made for the Steam version of the game.

NasierAlcofibras

  • Nameless
  • *
  • Posts: 4
  • Karma: 0
@Zor

Well, I mean I get the same error message that Dorogochi mentioned in his December 10, 2019 post here.

I'm citing it :

"When trying commands ill get "No matches. Was the game updated?" im on 2.1.0.4 ... this is outdated mod or ?"

The error message I receive is exactly : "Searching for function... No matches. Was the game updated?".

It seems something is wrong. I just realized that Augmentrex wass released for version 2.1.0.4 of the Steam flavor of the game.  Maybe I am mistaken on what the situation is ; for instance, maybe I get the error message for an other reason. By the way, I run 64 bit Windows 10 (1909) : could this be a problem ? Also I read that "Augmentrex requires .NET Framework 4.7.2 to run." I just tried to install it and the installer said .NET Framework 4.7.2 (or a more recent version of it) was already installed (and so did not re-install it).

Also, I have modified (shortly after its installation)  the Augmentrex.exe.config file at the end and the commands to execute at launch now read :

<add key="runCommands"
                 value="patch-cc-agent; patch-long-ray-vm;
                 key --add -s F1 patch-long-ray-vm" />

Maybe there are two errors there because the error message I mentioned above appears twice. Then it would be about the 2 patches (patch-cc-agent and patch-cc-agent) because adding the shorcut key was confirmed by the message "Added key binding: Shift+F1 = patch-long-ray-vm".

While in game, pressing Shift+F1 tries to execute patch-long-ray-vm but results in the same error message.

I have rewritten my own previous post in hope it would be clearer.

I admire all the persons who try to solve or reduce the problems with the Steam flavor of the game.

And I thank them.
« Last Edit: Aug 25, 2020; 08:22 AM by NasierAlcofibras »

Zor

  • Nameless
  • *
  • Posts: 14
  • Karma: 1
The game has not been updated on Steam for over 2 years, so that isn't the issue.

The message you're getting is because Augmentrex can't find the code it needs to patch in memory. It's kinda hard for me to say why that might be happening without being able to work directly on a machine that exhibits the problem; I can't reproduce the problem on my own machine.

My best guess would be that some Windows security feature or anti-malware software is unnecessarily interfering. You'll have to experiment a bit on your own to see if that's the case.

NasierAlcofibras

  • Nameless
  • *
  • Posts: 4
  • Karma: 0
@Zor

Thanks for replying so fast. (I was editing my post during that time...)

I'll look at my antivirus logs, try whitelisting the Augmentrex folder for the antivirus, and try deactivating some Windows own security features to see if I can find the culprit.

I'll keep you posted... but it may take a few days.

Thank you very much !

NasierAlcofibras

  • Nameless
  • *
  • Posts: 4
  • Karma: 0
@Zor

Hello again !

It took less time that I thought.

1) There was nothing about Augmentrex nor Hellgate London in my antivirus logs. My antivirus is 360 Total Security.

2) I added the folder (F:\SteamLibrary\steamapps\common\Augmentrex-2.0.0) containing Augmentrex and its files in the antivirus white list. The problem persists. This setting is now permanent.

3) I deactivated the antivirus using its turn-on/turn-off button but the problem persists. However for the next tests, the antivirus is turned ON.

4) Core isolation (using virtualization) was already deactivated on my machine before using Augmentrex because core isolation interfered with some other trusted application I use. It stays that way.

5) Secure boot was already activated on my machine before using Augmentrex. I have not tested deactivating it but I think it has nothing to do with the problem Augmentrex has.

6) The Windows defense against threats feature (accessible through Windows settings menus) contains several settings ; I have turned them all OFF, restarted Windows, tried Augmentrex but the problem persists. After the test, I turned them all ON (except one which is by default set to OFF) and restarted Windows.

Is there something else I could change for a testing ?  I could also give you remote access to my machine if required for faster checks and testing process. However you have to know that my Windows speaks French and it might be a problem (or not)... Living in the province of Quebec (Canada) I use a US-like keyboard (not the French one from France).

I hope French or English has nothing to do with my problem with Augmentrex... ??

Thanks again !